Random thoughts from an unusual company

How To Make Installing Connections 4 Impossible or IBM What Were You Thinking?

Gabriella Davis  10 September 2012 18:29:31
Tonight I decided to upgrade one of our servers to Connections 4.  I was involved in the beta but this server is still 3.0.1.1 so I start at the beginning, with the system requirements. What I want to know first is "should I upgrade Websphere".  Simple enough you'd think.  Start with a search for IBM Connections 4 System Requirements gives me this link

That's OK but it has a link to "requirements by type - software" - perfect that's what I want.  

Go take a look - anyone see the problem?  Yes that's right, I can only find out what version of WAS I need by clicking on the TINY LITTLE "I" icon to the right of each line.  That brings me another popup showing that I need 7.0.0.21.  

OK let's list the ways in which this is horirble

1. I am supposed to work out that the "i" has the detailed fixpack info
2. I have to click on an "i" for every single product to find out what its fixpack is
3. I then have to write down each product fixpack because that popup won't stay up
4. If things change I HAVE NO WAY OF KNOWING other than going in and clicking on every single little tiny "i" icon again
5. I can't print it.  How can I create a checklist for myself if I can't print it
6. Oh Look - there's an icon at the top to get a PDF.  Well done IBM, at least there's a PDF, I'll just grab that.. no hang on.. here's the PDF

GENIUS! The sound you hear is me banging my head on the table repeatedly.

Image:How To Make Installing Connections 4 Impossible or IBM What Were You Thinking?